using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+),([^,]+),(\d+)$";
string substitution = @"INSERT INTO cbl_student_competencies SET StudentID = $1, CompetencyID = (SELECT ID FROM cbl_competencies WHERE Code = ""$2""), Level = $3, EnteredVia = ""enrollment"" ON DUPLICATE KEY UPDATE Level = Level;";
string input = @"550,SS.2,10";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}