# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^'\w\s]|'(?![^\W\d_])|(?<![^\W\d_])')|(?='(?<=[^\W\d_]')(?=[^\W\d_]))|\s+/\n\1\n/gm;t' <<< "Who's kid are you? my ph. is +1-6466461022.'Bye!'
Who's kid are you? my ph. is +1-6466461022.Bye!"