use strict;
my $str = 'Who\'s kid are you? my ph. is +1-6466461022.\'Bye!\'
Who\'s kid are you? my ph. is +1-6466461022.Bye!';
my $regex = qr/([^'\w\s]|'(?![^\W\d_])|(?<![^\W\d_])')|(?='(?<=[^\W\d_]')(?=[^\W\d_]))|\s+/mp;
my $subst = '\\n\\1\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";