import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^'\\w\\s]|'(?![^\\W\\d_])|(?<![^\\W\\d_])')|(?='(?<=[^\\W\\d_]')(?=[^\\W\\d_]))|\\s+";
final String string = "Who's kid are you? my ph. is +1-6466461022.'Bye!'\n"
+ "Who's kid are you? my ph. is +1-6466461022.Bye!";
final String subst = "\\n\\1\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}