using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^'\w\s]|'(?![^\W\d_])|(?<![^\W\d_])')|(?='(?<=[^\W\d_]')(?=[^\W\d_]))|\s+";
string substitution = @"\n\1\n";
string input = @"Who's kid are you? my ph. is +1-6466461022.'Bye!'
Who's kid are you? my ph. is +1-6466461022.Bye!";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}