re = /([^'\w\s]|'(?![^\W\d_])|(?<![^\W\d_])')|(?='(?<=[^\W\d_]')(?=[^\W\d_]))|\s+/m
str = 'Who\'s kid are you? my ph. is +1-6466461022.\'Bye!\'
Who\'s kid are you? my ph. is +1-6466461022.Bye!'
subst = '\\n\\1\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result