import re
regex = re.compile(r"([^'\w\s]|'(?![^\W\d_])|(?<![^\W\d_])')|(?='(?<=[^\W\d_]')(?=[^\W\d_]))|\s+", flags=re.MULTILINE)
test_str = ("Who's kid are you? my ph. is +1-6466461022.'Bye!'\n"
"Who's kid are you? my ph. is +1-6466461022.Bye!")
subst = "\\n\\1\\n"
result = regex.sub(subst, test_str)
if result:
print(result)