#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=.*[a-fA-F]+)(?=.*[0-9]+)[a-zA-Z0-9]{10}"
Local $sString = "111111111a" & @CRLF & _
"7777dddddd" & @CRLF & _
"9999999999" & @CRLF & _
"88888888A" & @CRLF & _
"88888888AAA" & @CRLF & _
"88888A" & @CRLF & _
"AAAAAAAAA" & @CRLF & _
"" & @CRLF & _
"asdfasddad" & @CRLF & _
"bnmmnbamnb" & @CRLF & _
"8adfl9542a" & @CRLF & _
"ammmmmmmmm" & @CRLF & _
"mammmmmmmm" & @CRLF & _
"0mmmmmmmmm" & @CRLF & _
"m0ammmmmmm" & @CRLF & _
"on5pn0nmon" & @CRLF & _
"qqqq55511s" & @CRLF & _
"11111a1111" & @CRLF & _
"11111111111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")