using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*[a-fA-F]+)(?=.*[0-9]+)[a-zA-Z0-9]{10}";
string input = @"111111111a
7777dddddd
9999999999
88888888A
88888888AAA
88888A
AAAAAAAAA
asdfasddad
bnmmnbamnb
8adfl9542a
ammmmmmmmm
mammmmmmmm
0mmmmmmmmm
m0ammmmmmm
on5pn0nmon
qqqq55511s
11111a1111
11111111111";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}