const regex = /(?=.*[a-fA-F]+)(?=.*[0-9]+)[a-zA-Z0-9]{10}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=.*[a-fA-F]+)(?=.*[0-9]+)[a-zA-Z0-9]{10}', 'gm')
const str = `111111111a
7777dddddd
9999999999
88888888A
88888888AAA
88888A
AAAAAAAAA
asdfasddad
bnmmnbamnb
8adfl9542a
ammmmmmmmm
mammmmmmmm
0mmmmmmmmm
m0ammmmmmm
on5pn0nmon
qqqq55511s
11111a1111
11111111111`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}