re = /(?=.*[a-fA-F]+)(?=.*[0-9]+)[a-zA-Z0-9]{10}/m
str = '111111111a
7777dddddd
9999999999
88888888A
88888888AAA
88888A
AAAAAAAAA
asdfasddad
bnmmnbamnb
8adfl9542a
ammmmmmmmm
mammmmmmmm
0mmmmmmmmm
m0ammmmmmm
on5pn0nmon
qqqq55511s
11111a1111
11111111111'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end