import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.*[a-fA-F]+)(?=.*[0-9]+)[a-zA-Z0-9]{10}";
final String string = "111111111a\n"
+ "7777dddddd\n"
+ "9999999999\n"
+ "88888888A\n"
+ "88888888AAA\n"
+ "88888A\n"
+ "AAAAAAAAA\n\n"
+ "asdfasddad\n"
+ "bnmmnbamnb\n"
+ "8adfl9542a\n"
+ "ammmmmmmmm\n"
+ "mammmmmmmm\n"
+ "0mmmmmmmmm\n"
+ "m0ammmmmmm\n"
+ "on5pn0nmon\n"
+ "qqqq55511s\n"
+ "11111a1111\n"
+ "11111111111";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}