import Foundation
let pattern = #"(?=.*[a-fA-F]+)(?=.*[0-9]+)[a-zA-Z0-9]{10}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
111111111a
7777dddddd
9999999999
88888888A
88888888AAA
88888A
AAAAAAAAA
asdfasddad
bnmmnbamnb
8adfl9542a
ammmmmmmmm
mammmmmmmm
0mmmmmmmmm
m0ammmmmmm
on5pn0nmon
qqqq55511s
11111a1111
11111111111
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)