use strict;
my $str = '111111111a
7777dddddd
9999999999
88888888A
88888888AAA
88888A
AAAAAAAAA
asdfasddad
bnmmnbamnb
8adfl9542a
ammmmmmmmm
mammmmmmmm
0mmmmmmmmm
m0ammmmmmm
on5pn0nmon
qqqq55511s
11111a1111
11111111111';
my $regex = qr/(?=.*[a-fA-F]+)(?=.*[0-9]+)[a-zA-Z0-9]{10}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}