using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img [^<]*(height:[ \d]+px;?)[^>]*>";
string input = @"<div style=""height: 300px""><img style=""color:red;"" src=""#""><aaa style=""height:400px""><img src=""t.jpg"" title=""ā"" style=""width:1000px; height: 300px""><img src=""t.jpg"" style=""width:1000px; height: 500px""><eee src=""t.jpg"" style=""width:1000px; height: 500px""><img alt=""ķķ"" src=""#"" style=""height:2450px; visibility:hidden""/>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}