package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<img [^<]*(height:[ \d]+px;?)[^>]*>`)
var str = `<div style="height: 300px"><img style="color:red;" src="#"><aaa style="height:400px"><img src="t.jpg" title="ā" style="width:1000px; height: 300px"><img src="t.jpg" style="width:1000px; height: 500px"><eee src="t.jpg" style="width:1000px; height: 500px"><img alt="ķķ" src="#" style="height:2450px; visibility:hidden"/>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}