// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<img [^<]*(height:[ \d]+px;?)[^>]*>").unwrap();
let string = "<div style=\"height: 300px\"><img style=\"color:red;\" src=\"#\"><aaa style=\"height:400px\"><img src=\"t.jpg\" title=\"ā\" style=\"width:1000px; height: 300px\"><img src=\"t.jpg\" style=\"width:1000px; height: 500px\"><eee src=\"t.jpg\" style=\"width:1000px; height: 500px\"><img alt=\"ķķ\" src=\"#\" style=\"height:2450px; visibility:hidden\"/>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}