import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img [^<]*(height:[ \\d]+px;?)[^>]*>";
final String string = "<div style=\"height: 300px\"><img style=\"color:red;\" src=\"#\"><aaa style=\"height:400px\"><img src=\"t.jpg\" title=\"ā\" style=\"width:1000px; height: 300px\"><img src=\"t.jpg\" style=\"width:1000px; height: 500px\"><eee src=\"t.jpg\" style=\"width:1000px; height: 500px\"><img alt=\"ķķ\" src=\"#\" style=\"height:2450px; visibility:hidden\"/>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}