use strict;
my $str = '<div style="height: 300px"><img style="color:red;" src="#"><aaa style="height:400px"><img src="t.jpg" title="ā" style="width:1000px; height: 300px"><img src="t.jpg" style="width:1000px; height: 500px"><eee src="t.jpg" style="width:1000px; height: 500px"><img alt="ķķ" src="#" style="height:2450px; visibility:hidden"/>';
my $regex = qr/<img [^<]*(height:[ \d]+px;?)[^>]*>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}