re = /<img [^<]*(height:[ \d]+px;?)[^>]*>/
str = '<div style="height: 300px"><img style="color:red;" src="#"><aaa style="height:400px"><img src="t.jpg" title="ā" style="width:1000px; height: 300px"><img src="t.jpg" style="width:1000px; height: 500px"><eee src="t.jpg" style="width:1000px; height: 500px"><img alt="ķķ" src="#" style="height:2450px; visibility:hidden"/>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end