using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(""(?:\\.|[^""\\])*""|'(?:\\.|[^'\\])*')";
string substitution = @"Subbed";
string input = @"/*
this is comment block and should not be processed
var charName = ""johnson"";
*/
var charName = ""Alex"";";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}