re = /("(?:\\.|[^"\\])*"|'(?:\\.|[^'\\])*')/
str = '/*
this is comment block and should not be processed
var charName = "johnson";
*/
var charName = "Alex";'
subst = 'Subbed'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result