$re = '/("(?:\\\\.|[^"\\\\])*"|\'(?:\\\\.|[^\'\\\\])*\')/';
$str = '/*
this is comment block and should not be processed
var charName = "johnson";
*/
var charName = "Alex";';
$subst = "Subbed";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;