import re
regex = re.compile(r"(\"(?:\\.|[^\"\\])*\"|'(?:\\.|[^'\\])*')")
test_str = ("/*\n"
"this is comment block and should not be processed\n"
"var charName = \"johnson\";\n"
"*/\n"
"var charName = \"Alex\";")
subst = "Subbed"
result = regex.sub(subst, test_str)
if result:
print(result)