const regex = /("(?:\\.|[^"\\])*"|'(?:\\.|[^'\\])*')/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('("(?:\\\\.|[^"\\\\])*"|\'(?:\\\\.|[^\'\\\\])*\')', 'g')
const str = `/*
this is comment block and should not be processed
var charName = "johnson";
*/
var charName = "Alex";`;
const subst = `Subbed`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);