package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`("(?:\\.|[^"\\])*"|'(?:\\.|[^'\\])*')`)
var str = `/*
this is comment block and should not be processed
var charName = "johnson";
*/
var charName = "Alex";`
var substitution = "Subbed"
fmt.Println(re.ReplaceAllString(str, substitution))
}