# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:src|href)\s*=\s*")((?!{{\s*asset)[^"]+)/$1{{asset('$2')}}/gm;t' <<< "<img src=\"icons/google-icon.svg\" >
//Replace to:
<img src=\"{{asset('icons/google-icon.svg')}}\" >
//Find:
<link href=\"css/style.css\">
//Replace to:
<link href=\"{{asset('css/style.css')}}\">"