use strict;
my $str = '<img src="icons/google-icon.svg" >
//Replace to:
<img src="{{asset(\'icons/google-icon.svg\')}}" >
//Find:
<link href="css/style.css">
//Replace to:
<link href="{{asset(\'css/style.css\')}}">';
my $regex = qr/((?:src|href)\s*=\s*")((?!{{\s*asset)[^"]+)/mp;
my $subst = '$1{{asset(\'$2\')}}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";