# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:src|href)\s*=\s*\")((?!{{\s*asset)[^\"]+)"
test_str = ("<img src=\"icons/google-icon.svg\" > \n"
"//Replace to: \n"
"<img src=\"{{asset('icons/google-icon.svg')}}\" >\n\n"
"//Find:\n"
"<link href=\"css/style.css\"> \n"
"//Replace to: \n"
"<link href=\"{{asset('css/style.css')}}\">")
subst = "$1{{asset('$2')}}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.