import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:src|href)\\s*=\\s*\")((?!\\{\\{\\s*asset)[^\"]+)";
final String string = "<img src=\"icons/google-icon.svg\" > \n"
+ "//Replace to: \n"
+ "<img src=\"{{asset('icons/google-icon.svg')}}\" >\n\n"
+ "//Find:\n"
+ "<link href=\"css/style.css\"> \n"
+ "//Replace to: \n"
+ "<link href=\"{{asset('css/style.css')}}\">";
final String subst = "$1{{asset('$2')}}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}