# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<\?php(.*?)\?>//gs;t' <<< "<html>
<head>
<title>Test</title>
</head>
<body>
<div> <a href=\"test1.html\" title=\"test\"></a>
<?php
$result_array=\"123\";
if ($result_array==\"123\")
{
?>
<a href=\"test4.html\" title=\"tesdfhdfhdfht2\"></a>
<?php
else{
?>
<a href=\"test5.html\" title=\"tedfhdfhst\"></a>
<?php
}
?>
</div>
</body>
</html>
"