import re
regex = re.compile(r"<\?php(.*?)\?>", flags=re.DOTALL)
test_str = ("<html>\n"
" <head>\n"
" <title>Test</title>\n"
" </head>\n"
" <body>\n"
" <div> <a href=\"test1.html\" title=\"test\"></a>\n"
" <?php\n\n"
" $result_array=\"123\";\n\n"
" if ($result_array==\"123\")\n"
" {\n"
" ?>\n"
" <a href=\"test4.html\" title=\"tesdfhdfhdfht2\"></a>\n"
" <?php \n\n\n"
" else{\n\n"
" ?>\n"
" <a href=\"test5.html\" title=\"tedfhdfhst\"></a>\n"
" <?php\n\n\n"
" }\n\n"
" ?>\n"
" </div>\n"
" </body>\n"
" </html>\n\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)