using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\?php(.*?)\?>";
string substitution = @"";
string input = @"<html>
<head>
<title>Test</title>
</head>
<body>
<div> <a href=""test1.html"" title=""test""></a>
<?php
$result_array=""123"";
if ($result_array==""123"")
{
?>
<a href=""test4.html"" title=""tesdfhdfhdfht2""></a>
<?php
else{
?>
<a href=""test5.html"" title=""tedfhdfhst""></a>
<?php
}
?>
</div>
</body>
</html>
";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}