import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\?php(.*?)\\?>";
final String string = "<html>\n"
+ " <head>\n"
+ " <title>Test</title>\n"
+ " </head>\n"
+ " <body>\n"
+ " <div> <a href=\"test1.html\" title=\"test\"></a>\n"
+ " <?php\n\n"
+ " $result_array=\"123\";\n\n"
+ " if ($result_array==\"123\")\n"
+ " {\n"
+ " ?>\n"
+ " <a href=\"test4.html\" title=\"tesdfhdfhdfht2\"></a>\n"
+ " <?php \n\n\n"
+ " else{\n\n"
+ " ?>\n"
+ " <a href=\"test5.html\" title=\"tedfhdfhst\"></a>\n"
+ " <?php\n\n\n"
+ " }\n\n"
+ " ?>\n"
+ " </div>\n"
+ " </body>\n"
+ " </html>\n\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}