import Foundation
let pattern = #"<\?php(.*?)\?>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<html>
<head>
<title>Test</title>
</head>
<body>
<div> <a href="test1.html" title="test"></a>
<?php
$result_array="123";
if ($result_array=="123")
{
?>
<a href="test4.html" title="tesdfhdfhdfht2"></a>
<?php
else{
?>
<a href="test5.html" title="tedfhdfhst"></a>
<?php
}
?>
</div>
</body>
</html>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)