#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)<\?php(.*?)\?>"
Local $sString = "<html>" & @CRLF & _
" <head>" & @CRLF & _
" <title>Test</title>" & @CRLF & _
" </head>" & @CRLF & _
" <body>" & @CRLF & _
" <div> <a href="test1.html" title="test"></a>" & @CRLF & _
" <?php" & @CRLF & _
"" & @CRLF & _
" $result_array="123";" & @CRLF & _
"" & @CRLF & _
" if ($result_array=="123")" & @CRLF & _
" {" & @CRLF & _
" ?>" & @CRLF & _
" <a href="test4.html" title="tesdfhdfhdfht2"></a>" & @CRLF & _
" <?php " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" else{" & @CRLF & _
"" & @CRLF & _
" ?>" & @CRLF & _
" <a href="test5.html" title="tedfhdfhst"></a>" & @CRLF & _
" <?php" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" ?>" & @CRLF & _
" </div>" & @CRLF & _
" </body>" & @CRLF & _
" </html>" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)