#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^\W+"
Local $sString = " YES leading spaces are valid, problemsetters are evillllll"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)