use strict;
my $str = ' YES leading spaces are valid, problemsetters are evillllll';
my $regex = qr/^\W+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";