$re = '/^\W+/';
$str = ' YES leading spaces are valid, problemsetters are evillllll';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;