re = /^\W+/
str = ' YES leading spaces are valid, problemsetters are evillllll'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result