using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^a-zA-Z,]\d+((\,\d+(\+|\-|\*|\/)\d+(\,\d+|))|((\+|\-|\*|\/)(\d+(\,\d+|))))";
string input = @"10,10 + 9, 9
10,1,0+9,9
10,10,+,9,9
10,10+9,9
10+9,0
10,0+9
10+9
10,0+9,4
10,2+3
,?(\d+)?|(\+|-|\*|\/|\,|)
(\+|\-|\*|\/)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}