re = /[^a-zA-Z,]\d+((\,\d+(\+|\-|\*|\/)\d+(\,\d+|))|((\+|\-|\*|\/)(\d+(\,\d+|))))/
str = '10,10 + 9, 9
10,1,0+9,9
10,10,+,9,9
10,10+9,9
10+9,0
10,0+9
10+9
10,0+9,4
10,2+3
,?(\\d+)?|(\\+|-|\\*|\\/|\\,|)
(\\+|\\-|\\*|\\/)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end