package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^a-zA-Z,]\d+((\,\d+(\+|\-|\*|\/)\d+(\,\d+|))|((\+|\-|\*|\/)(\d+(\,\d+|))))`)
var str = `10,10 + 9, 9
10,1,0+9,9
10,10,+,9,9
10,10+9,9
10+9,0
10,0+9
10+9
10,0+9,4
10,2+3
,?(\d+)?|(\+|-|\*|\/|\,|)
(\+|\-|\*|\/)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}