# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^a-zA-Z,]\d+((\,\d+(\+|\-|\*|\/)\d+(\,\d+|))|((\+|\-|\*|\/)(\d+(\,\d+|))))"
test_str = ("10,10 + 9, 9\n"
"10,1,0+9,9\n"
"10,10,+,9,9\n"
"10,10+9,9\n"
"10+9,0\n"
"10,0+9\n"
"10+9\n"
"10,0+9,4\n"
"10,2+3\n\n"
",?(\\d+)?|(\\+|-|\\*|\\/|\\,|)\n"
"(\\+|\\-|\\*|\\/)")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.