package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)<actor=(?'actor'\w+)(?:\s(?'k1'\w+)(?:=(?'v1'\w+?|'.+?'))?)?(?:\s(?'k2'\w+)(?:=(?'v2'\w+?|'.+?'))?)?(?:\s(?'k3'\w+)(?:=(?'v3'\w+?|'.+?'))?)?(?:\s(?'k4'\w+)(?:=(?'v4'\w+?|'.+?'))?)?>(?:(?:(?'content'.+)<\/actor>(?'extra'.*))|(?'contentonly'.*))`)
var str = `<actor=vencil lookat=beatrice enter transfer=vencil setconvo='Vencil 1'>Vencil's speech</actor>Extra stuff`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}