re = /<actor=(?'actor'\w+)(?:\s(?'k1'\w+)(?:=(?'v1'\w+?|'.+?'))?)?(?:\s(?'k2'\w+)(?:=(?'v2'\w+?|'.+?'))?)?(?:\s(?'k3'\w+)(?:=(?'v3'\w+?|'.+?'))?)?(?:\s(?'k4'\w+)(?:=(?'v4'\w+?|'.+?'))?)?>(?:(?:(?'content'.+)<\/actor>(?'extra'.*))|(?'contentonly'.*))/
str = '<actor=vencil lookat=beatrice enter transfer=vencil setconvo=\'Vencil 1\'>Vencil\'s speech</actor>Extra stuff'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end