import Foundation
let pattern = #"<actor=(?'actor'\w+)(?:\s(?'k1'\w+)(?:=(?'v1'\w+?|'.+?'))?)?(?:\s(?'k2'\w+)(?:=(?'v2'\w+?|'.+?'))?)?(?:\s(?'k3'\w+)(?:=(?'v3'\w+?|'.+?'))?)?(?:\s(?'k4'\w+)(?:=(?'v4'\w+?|'.+?'))?)?>(?:(?:(?'content'.+)<\/actor>(?'extra'.*))|(?'contentonly'.*))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"<actor=vencil lookat=beatrice enter transfer=vencil setconvo='Vencil 1'>Vencil's speech</actor>Extra stuff"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)