use strict;
my $str = '<actor=vencil lookat=beatrice enter transfer=vencil setconvo=\'Vencil 1\'>Vencil\'s speech</actor>Extra stuff';
my $regex = qr/<actor=(?'actor'\w+)(?:\s(?'k1'\w+)(?:=(?'v1'\w+?|'.+?'))?)?(?:\s(?'k2'\w+)(?:=(?'v2'\w+?|'.+?'))?)?(?:\s(?'k3'\w+)(?:=(?'v3'\w+?|'.+?'))?)?(?:\s(?'k4'\w+)(?:=(?'v4'\w+?|'.+?'))?)?>(?:(?:(?'content'.+)<\/actor>(?'extra'.*))|(?'contentonly'.*))/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}