const regex = /<actor=(?'actor'\w+)(?:\s(?'k1'\w+)(?:=(?'v1'\w+?|'.+?'))?)?(?:\s(?'k2'\w+)(?:=(?'v2'\w+?|'.+?'))?)?(?:\s(?'k3'\w+)(?:=(?'v3'\w+?|'.+?'))?)?(?:\s(?'k4'\w+)(?:=(?'v4'\w+?|'.+?'))?)?>(?:(?:(?'content'.+)<\/actor>(?'extra'.*))|(?'contentonly'.*))/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<actor=(?\'actor\'\\w+)(?:\\s(?\'k1\'\\w+)(?:=(?\'v1\'\\w+?|\'.+?\'))?)?(?:\\s(?\'k2\'\\w+)(?:=(?\'v2\'\\w+?|\'.+?\'))?)?(?:\\s(?\'k3\'\\w+)(?:=(?\'v3\'\\w+?|\'.+?\'))?)?(?:\\s(?\'k4\'\\w+)(?:=(?\'v4\'\\w+?|\'.+?\'))?)?>(?:(?:(?\'content\'.+)<\\\/actor>(?\'extra\'.*))|(?\'contentonly\'.*))', 'gs')
const str = `<actor=vencil lookat=beatrice enter transfer=vencil setconvo='Vencil 1'>Vencil's speech</actor>Extra stuff`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}