import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<actor=(?'actor'\\w+)(?:\\s(?'k1'\\w+)(?:=(?'v1'\\w+?|'.+?'))?)?(?:\\s(?'k2'\\w+)(?:=(?'v2'\\w+?|'.+?'))?)?(?:\\s(?'k3'\\w+)(?:=(?'v3'\\w+?|'.+?'))?)?(?:\\s(?'k4'\\w+)(?:=(?'v4'\\w+?|'.+?'))?)?>(?:(?:(?'content'.+)<\\/actor>(?'extra'.*))|(?'contentonly'.*))";
final String string = "<actor=vencil lookat=beatrice enter transfer=vencil setconvo='Vencil 1'>Vencil's speech</actor>Extra stuff";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}